VIOS Commands
http://www.aixmind.com/?p=1904
AIX Solaris HPUX UNIX Linux system storage administration ksh/perl scripting
?
UNIX administrator blog tips experience command log knowledge base
December 7, 2010 12:54 pm
Virtual I/O Server(VIOS) useful commands
by admin in AIX
Initialize the LPAR Configuration :
# mkgencfg -o init
[OS] Software Management :
To display VIO Server level:
# ioslevel
To update the IOS software:
# updateios –dev /update -
To installs a new filesets (mainly used for TL updates):
# updateios –dev /cd0 -install -accept
To commit all applied :
# updateios –commit
To rejects all uncommitted updates :
# updateios –reject
To clean all incomplete pieces of the previous installation :
# updateios –clean
To remove a fileset :
# updateios –remove fileset_name
To take the OS backup in a CD ROM :
# backupios –cd /dev/cd1 -cdformat
To take the OS backup in a DVD-RAM :
# backupios –cd /dev/cd1 -udf
To take the OS backup in a tape drive :
# backupios –tape /dev/rmt0
Just verifies the backup available in a tape :
# backupios –tape /dev/rmt0 -verify
Generates backup to a file. No user VGs are -nosvg back’d up :
# backupios –file /opt/file1
To display the underlying AIX OS version :
# oem_platform_level
To open a non-restricted root shell :
# oem_setup_env
This shell is used mainly for the installation of vendor software such as device drivers.
Remote Management :
To enable remote_management using NIM master :
# remote_management nim1
To disable remote management :
# remote_management –disable
License Management:
To display the current license :
# license –view
To accept the license :
# license –accept
To view if the license has been accepted :
# license
Software Management:
To list all the installed software :
# lssw
To list all the installed software and their history
# lssw –hist
Management of Virtual Terminals:
To open a virtual terminal for partition with id 2 :
# mkvt –id
To close a virtual terminal for a partition with id 2 :
# rmvt –id 2
Device Management:
To change the attribute of a device permanently.
# chdev -dev scsi0 -attr -perm
Sometimes it reboots the system if perm is used
To disable the path between hdisk1 and scsi0 :
# chpath -dev hdisk1 -pdev scsi0 -op disable
To configures the devices in the VIO server :
# cfgdev
To configures the devices attached to scsi0 adapter :
# cfgdev –dev
To unconfigure the cd-rom device :
# rmdev –dev cd0
To unconfigure scsi adapter and its child devices :
# rmdev –recursive –dev scsi1
To unconfigures the children of pci1 but not the PCI bus pci1 :
# rmdev –pdev pci1
Management of Virtual/Shared Devices:
To create a virtual target device that maps lv20 as a virtual disk for a client partition hosted by the vhost0 virtual server adapter :
# mkvdev -vdev lv20 -vadapter vhost0
Same as above except here hdisk is used instead of a logical volume :
# mkvdev -vdev hdisk6 -vadapter vhost2
To create a SEA that maps the physical Ethernet adapter ent4 as a virtual adapter for the client
partitions served by the virtual Ethernet adapters ent6 and ent7, using ent6 as the default adapter and 8 as the default id :
# mkvdev -sea ent4 -vadapter ent6,ent7 -default ent6 -defaultid 8
To remove a virtual target device vtscsi9 along with its backing lv :
# rmvdev –vdev vtscsi9 –
To remove all virtual target device associated with backing device lv001 :
# rmvdev –vdev lv001
To remove a specific virtual target device :
# rmvdev –vtd vtscsi10
List Device Mapping:
To list all virtual target devices and backing devices mapped to virtual server adapter vhost2 :
# lsmap -vadapter vhost2
To list SEA and physical device mapped to virtual Ethernet Adapter ent4 :
# lsmap -vadapter ent4 –net
To list all virtual target devices and backing devices where backing devices are of type LV :
# lsmap -all -type lv
To list all network mapping :
# lsmap –all –net
How to list Devices :
To display all the devices :
# lsdev
To display all the virtual devices :
# lsdev –virtual
To display all the virtual adapters :
# lsdev –type adapter –virtual
To display all the slots :
# lsdev –slot s
To display all the adapters :
# lsdev –type adapter
Few other device types: disk, lv, optical, tape, tty
To list all physical Ethernet adapters and Etherchannel available for creating a SEA :
# lsdev –type ent4sea
To list all virtual Ethernet adapters available for creating a SEA :
# lsdev –type ven4sea
To list all adapters over which ip address can be configured :
# lsdev –type ent4ip
To display parent device of a device :
# lsdev –dev hdisk0 –
To list disks names and physical location alone :
# lsdev -type disk -field name physloc
Logical Volume Manager :
Volume Group
To create a vg on hdisk1 :
# mkvg -vg newvg hdisk1
To drain I/O’s for a vg and suspends future I/O’s :
# chvg -suspend vg03
To resume normal I/O operations for a vg :
# chvg -resume vg03
Unlock a VG if left in a locked state by abnormal termination of another lvm operation :
# chvg -unlock vg03
To add a physical volume to a volume group :
# extendvg vg3 hdisk3
To remove a PV from a VG :
# reducevg vg01 hdisk1
To remove a PV and all residing LVs from a VG with no confirmation :
# reducevg –rmlv –f vg01
To activate a vg :
# activatevg vg03
To deactivate a vg :
# deactivatevg vg03
To mirror the VIO Server’s rootvg to hdisk4 and reboots VIO Server :
# mirrorios –force hdisk4
To mirror the VIO Server’s rootvg to hdisk4 but don’t reboot the server :
# mirrorios –defer hdisk4
To remove the rootvg mirror from hdisk4 :
# unmirrorios hdisk4
To import a VG from hdisk07 :
# importvg –vg vg001 hdisk07
To export a VG :
# exportvg vg3
Note: Volume Group containing a paging space can’t be exported
To sync a VG :
# syncvg –vg vg01
To sync a LV :
# syncvg –lv lv001
To sync a PV :
# syncvg –pv hdisk4 hdisk5
To redefine a VG based on the VGDA from hdisk04 :
# redefvg –dev hdisk04
Logical Volume :
To create a logical volume of size 1MB in vg01 :
# mklv –lv lv001 vg01 1M hdisk1
To create a logical volume with mirror in place in vg01 of size 1GB :
# mklv –mirror vg01 1G
To extend an LV by 3MB :
# extendlv lv01 3M
To extend an LV by 1GB with space taken from hdisk5 :
# extendlv lv01 1G hdisk5
To remove a logical volume :
# rmlv lv05
To display the properties of a logical volume :
# lslv lv03
To display info about LV by Physical volume :
# lslv –pv lv03
To display LVs that can be used as backing devices :
# lslv –free
To make a copy for lv01 in hdisk03 :
# mklvcopy lv01 hdisk03
To remove lv01’s copy from hdisk03 :
# rmlvcopy lv01 hdisk03
To copy the contents of lv01 to lv02 :
# cplv lv01 lv02
To copy the contents of lv01 to a new lv in vg01 :
# cplv –vg vg01 lv01
To change the name of oldlv to newlv :
# chlv –lv newlv oldlv
Physical Volume
To display all physical volumes in the system :
# lspv
To display the status and characteristics of hdisk03 :
# lspv hdisk03
To list all the available PVs used as virtual SCSI backing devices :
# lspv –avail
To list PVs that can be used as virtual SCSI backing devices and are not currently a backing device :
# lspv –free
To move physical partitions from hdisk1 to hdisk2 :
# migratepv hdisk1 hdisk2
To move physical partitions in lv01 from hdisk1 to hdisk2 :
# migratepv –lv lv01 hdisk1 hdisk2
Storage Pool Management:
To create storage pool “client_data” using hdisk3 hdisk4 hdisk3 and hdisk4 :
# mksp -f client_data
To set client_data storage pool as default :
# chsp –default client_data
To list all storage pools :
# lssp
To list the default storage pool :
# lssp –default
To list the backing device in rootvg storage pool :
# lssp –bd –sp rootvg
To attach a storage from a storage pool to a Virtual SCSI adapter:
# mkbdsp -bd lv001 -vadapter vthost2 -tn vtscsi9
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –bd lv001
To remove storage from a Virtual SCSI adapter, And makes sure backing device is not deleted :
# rmbdsp –bd lv001 -savebd
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –vtd vtscsi9
To removes storage from a Virtual SCSI adapter. and makes sure backing device is not deleted :
# rmbdsp –vtd vtscsi8 -savebd
Network Configuration :
TCP/IP Configation:
To configure tcpip on a network interface :
# mktcpip -hostname sys01vio2 -inetaddr 9.47.90.113 -interface en2 -netmask 255.255.255.0 -gateway 9.47.90.1 -nsrvdomain yahoo.com -start
-
To display the stored tcp/ip configuration in the system :
# lstcpip –stored
To display ethernet adapters on the system :
# lstcpip –adapters
To display the system hostname :
# lstcpip –hostname
To display DNS name servers in search order and domain name :
# lstcpip –namesrv
To display the routing table :
# lstcpip –routtable
To display routing table in numeric output instead of hostname :
# lsctpip –num –routtable
To display all the open inet sockets :
# lstcpip –sockets –family inet
To display the status of all configured interfaces :
# lstcpip –state
To remove all TCP/IP configuration :
# rmtcpip –all
To unconfigure tcpip in en0:
# rmtcpip –interface en0
To cleanup static routing table :
# rmtcpip –f -routing
To remove IP information from en0 after reboot :
# rmtcpip –f –interface en0 -nextboot
To remove DNS information and clears the hosts file :
# rmcpip –namesrv
Managing IP address-to-host name Mapping Entries:
To add IP address-to-host name mapping entry :
# hostmap -addr 192.100.1.7 -host alpha
To list all IP address-to-host name mapping entries :
# hostmap –ls
To delete the IP address-to-host name mapping entry :
# hostmap-rm 192.100.1.7
Managing Network Services:
To enable all the network services :
# startnetsvc ALL
To enable the telnet daemon :
# startnetsvc telnet
To enable the ftp daemon :
# startnetsvc ftp
To enable the ssh daemon :
# startnetsvc ssh
To enable the ldap daemon :
# startnetsvc ldap
To enable the cimserver daemon :
# startnetsvc cimserver
To enable the xntpd daemon :
# startnetsvc xntpd
To send CLI tracing details to the system log :
# startnetsvc tracelog
To send system error to the system log :
# startnetsvc errorlog
To disable all the network services :
# stopnetsvc ALL
To disable the telnet daemon :
# stopnetsvc telnet
To disable the ftp daemon :
# stopnetsvc ftp
To disable the ssh daemon :
# stopnetsvc ssh
To disable the ldap daemon :
# stopnetsvc ldap
To disable the cimserver daemon :
# stopnetsvc cimserver
To disable the xntpd daemon :
stopnetsvc xntpd
To stop sending CLI tracing details to system log :
# stopnetsvc tracelog
To stop sending system error log to the system log :
# stopnetsvc errorlog -
To display the status of ftp network service :
# lsnetsvc ftp
Managing DNS, Domain and Search Order Entries:
To add a domain entry :
# cfgnamesrv -add -dname abc.aus.century.com
To add a name server entry :
# cfgnamesrv –add -ipaddr 192.9.201.1
To display all the DNS entries :
# cfgnamesrv -ls
Network Tuning Parameters:
To display the maximum size of the mbuf pool :
# optimizenet –get thewall
To set a machine as internet work router over TCP/IP networks :
# optimizenet –set ipforwarding=1
To display information on udp_recvspace :
# optimizenet –h udp_recvspace
Network Monitoring:
To display all the statistics, including the device- specific statistics :
# entstat ent0
To reset all the statistics back to their initial values :
# entstat –reset ent0
To display the route to a particular host :
# traceroute nis.nsf.net
System Monitoring :
To display the summary of current system activity :
# sysstat
To display the system statistics :
# topas
System Management Commands:
To halt the operating system :
# shutdown
To halt the operating system forcibly :
# shutdown –force
To reboot the vio server :
# shutdown –restart
To invalidate the boot list for service mode :
# bootlist -mode service –rm
To display the boot list for service mode :
# bootlist -mode service –ls
To set the boot list for normal mode :
# bootlist –more normal hdisk0
To display the complete detailed error report :
# errlog –ls
To remove all the error log entries :
# errlog –rm 0
To remove the error log entries older than 5 days :
# errlog –rm 5
To change the system date and time :
# chdate -day 12 -month 10 -year 2004 -hour 16 -minute 30
To change the language for the entire system to French Canadian :
# chlang -lang fr_CA
To display available languages :
# chlang –ls
To perform hardware problem determination and maintenance :
# diagmenu
To generate report on microcode levels of all the devices :
# invscout –report
To display the vpd survey of the partition :
# invscout –vpd
To append the current MOTD [Message Of The Day] :
# motd –append “Message”
To overwrite MOTD :
# motd –overwrite -file filename
To do the initial configuration of VIO Server :
# cfgassist
It is like configuration assitant in AIX.
To do filesystem scan :
# fsck /dev/lv01
To display exported (nfs) directories on a remote server :
# showmount hostname
To start system dump on the primary device :
# startsysdump
To display continuous disk report on disk1 at 2sec interval :
# viostat -disk disk1 2
To display adapter throughput reports :
# viostat –adapter
To display system and adapter throughput reports :
# viostat –sys –adapter
To gather system info and to store it in the floppy disk :
# snap -general -dev /dev/rfd0
To display microcode levels of all devices :
# lsfware –all
Managing Agents:
To start an agent : # startsvc agent_name
To stop an agent: # stopsvc agent_name
To display an agent’s configuration information :
# lssvc agent_name
To display all the available agents :
# lssvc
To display the attributes associated with ITSM_base agent :
# cfgsvc –ls ITM_base
To display the ITM_base agent ssh public key :
# cfgsvc -key ITM_base
User Management:
To create a user :
# mkuser
To change an attribute of a user :
# chuser
To display the properties of a user :
# lsuser
To remove a user from the system :
# rmuser
To set/reset password for a user :
# passwd
Security Commands:
To display all failed logins :
# lsfailedlogin
To display the contents of global command log :
# lsgcl
To displays high system settings :
# viosecure -level high
To apply all of the high system settings to the system :
# viosecure -level high –apply
To displays the current system settings :
# viosecure –view
To allow IP activity on the ftp-data, ftp, ssh, www, https, rmc, and cimon ports, and to deny other IP activity :
# viosecure –firewall on
To enable IP activity on all ports :
# viosecure –firewall off
To display the list of allowed ports :
# viosecure -firewall view
tags: command, VIOS, Virtual-I/O-Server
« Adding a disk to GPFS filesystem Dynamically « newer
older » Run “update_all” using command line »
No Responses to "Virtual I/O Server(VIOS) useful commands". Add a comment? or Follow comments by RSS?
Be the first and share your thoughts!
Please leave a comment...
Stay behind your words, use your real name or nickname.
name »
e-mail »
site »
Please be nice and tolerant, don't offend. Thanks!
Home
About
RSS Feed
Search for:
May 2012 M T W T F S S
« Apr
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31
Tag cloud
SEA HACMP Oracle NIC command LDAP VIO recovery HMC IBM AIX ODM mksysb filesystem process lvm powerha sendmail backup VG console login NIM tuning NPIV tcpip network restore jfs2 TSM VIOS performance disk GPFS device paging-space security SSH debug Boot WPAR Error linux NFS Remove
Categories
AIX (816)
application (8)
Cluster (27)
Database (13)
Fun (5)
HPUX (6)
linux (32)
Misc (5)
network (6)
Perl (5)
security (2)
Shell Script (27)
Solaris (29)
Storage (35)
TSM (20)
UNIX (3)
UNIX Interview questions and answers (3)
Virtualization (23)
Webspere (1)
Blogcatalog
Technology Blogs - Blog Catalog Blog Directory
Promote Your Blog
Recent Posts
List WWPN of all LPARs or a specific LPAR using HMC command
Yup, another PowerHA bug! cl_chfs: VG sharedvg is concurrent
Determining if TSAMP/RSCT rebooted a node/server
GPFS filesystem outage with a kernel panic 225E3B63
DBI1122E after using db2iupdt command on existing instance
Oracle installation compiler requirement
MustGather: No response (hang) on AIX 5.2 and higher versions produces no javacore
SEA Failover flapping on backup SEA
Optimizing Sybase Adaptive Server Enterprise (ASE) for IBM AIX
Upgrading CAA in a PowerHA v7.1 Cluster
SAS 9.2 on IBM AIX 7.1: Tuning guideline
SAS on IBM AIX 6.1: Tuning guidelines
SAS AIX 5L Tuning Guide
Running SAS applications on Virtual I/O based storage configuration
Live Partition Mobility for Oracle RAC
Search Engine Optimization and SEO Tools
TopOfBlogs
Search Engine Submission - AddMe
Blogroll
Themes
UNIX
unix.com
Meta
Log in
RSS Feed
Comments RSS
AIX Solaris HPUX UNIX Linux system storage administration ksh/perl scripting 2010. "Life is Simple" is a simple theme for WordPress, powered by Chereshka.
StatCounter - Free Web Tracker and Counter
AIX Solaris HPUX UNIX Linux system storage administration ksh/perl scripting
?
UNIX administrator blog tips experience command log knowledge base
December 7, 2010 12:54 pm
Virtual I/O Server(VIOS) useful commands
by admin in AIX
Initialize the LPAR Configuration :
# mkgencfg -o init
[OS] Software Management :
To display VIO Server level:
# ioslevel
To update the IOS software:
# updateios –dev /update -
To installs a new filesets (mainly used for TL updates):
# updateios –dev /cd0 -install -accept
To commit all applied :
# updateios –commit
To rejects all uncommitted updates :
# updateios –reject
To clean all incomplete pieces of the previous installation :
# updateios –clean
To remove a fileset :
# updateios –remove fileset_name
To take the OS backup in a CD ROM :
# backupios –cd /dev/cd1 -cdformat
To take the OS backup in a DVD-RAM :
# backupios –cd /dev/cd1 -udf
To take the OS backup in a tape drive :
# backupios –tape /dev/rmt0
Just verifies the backup available in a tape :
# backupios –tape /dev/rmt0 -verify
Generates backup to a file. No user VGs are -nosvg back’d up :
# backupios –file /opt/file1
To display the underlying AIX OS version :
# oem_platform_level
To open a non-restricted root shell :
# oem_setup_env
This shell is used mainly for the installation of vendor software such as device drivers.
Remote Management :
To enable remote_management using NIM master :
# remote_management nim1
To disable remote management :
# remote_management –disable
License Management:
To display the current license :
# license –view
To accept the license :
# license –accept
To view if the license has been accepted :
# license
Software Management:
To list all the installed software :
# lssw
To list all the installed software and their history
# lssw –hist
Management of Virtual Terminals:
To open a virtual terminal for partition with id 2 :
# mkvt –id
To close a virtual terminal for a partition with id 2 :
# rmvt –id 2
Device Management:
To change the attribute of a device permanently.
# chdev -dev scsi0 -attr -perm
Sometimes it reboots the system if perm is used
To disable the path between hdisk1 and scsi0 :
# chpath -dev hdisk1 -pdev scsi0 -op disable
To configures the devices in the VIO server :
# cfgdev
To configures the devices attached to scsi0 adapter :
# cfgdev –dev
To unconfigure the cd-rom device :
# rmdev –dev cd0
To unconfigure scsi adapter and its child devices :
# rmdev –recursive –dev scsi1
To unconfigures the children of pci1 but not the PCI bus pci1 :
# rmdev –pdev pci1
Management of Virtual/Shared Devices:
To create a virtual target device that maps lv20 as a virtual disk for a client partition hosted by the vhost0 virtual server adapter :
# mkvdev -vdev lv20 -vadapter vhost0
Same as above except here hdisk is used instead of a logical volume :
# mkvdev -vdev hdisk6 -vadapter vhost2
To create a SEA that maps the physical Ethernet adapter ent4 as a virtual adapter for the client
partitions served by the virtual Ethernet adapters ent6 and ent7, using ent6 as the default adapter and 8 as the default id :
# mkvdev -sea ent4 -vadapter ent6,ent7 -default ent6 -defaultid 8
To remove a virtual target device vtscsi9 along with its backing lv :
# rmvdev –vdev vtscsi9 –
To remove all virtual target device associated with backing device lv001 :
# rmvdev –vdev lv001
To remove a specific virtual target device :
# rmvdev –vtd vtscsi10
List Device Mapping:
To list all virtual target devices and backing devices mapped to virtual server adapter vhost2 :
# lsmap -vadapter vhost2
To list SEA and physical device mapped to virtual Ethernet Adapter ent4 :
# lsmap -vadapter ent4 –net
To list all virtual target devices and backing devices where backing devices are of type LV :
# lsmap -all -type lv
To list all network mapping :
# lsmap –all –net
How to list Devices :
To display all the devices :
# lsdev
To display all the virtual devices :
# lsdev –virtual
To display all the virtual adapters :
# lsdev –type adapter –virtual
To display all the slots :
# lsdev –slot s
To display all the adapters :
# lsdev –type adapter
Few other device types: disk, lv, optical, tape, tty
To list all physical Ethernet adapters and Etherchannel available for creating a SEA :
# lsdev –type ent4sea
To list all virtual Ethernet adapters available for creating a SEA :
# lsdev –type ven4sea
To list all adapters over which ip address can be configured :
# lsdev –type ent4ip
To display parent device of a device :
# lsdev –dev hdisk0 –
To list disks names and physical location alone :
# lsdev -type disk -field name physloc
Logical Volume Manager :
Volume Group
To create a vg on hdisk1 :
# mkvg -vg newvg hdisk1
To drain I/O’s for a vg and suspends future I/O’s :
# chvg -suspend vg03
To resume normal I/O operations for a vg :
# chvg -resume vg03
Unlock a VG if left in a locked state by abnormal termination of another lvm operation :
# chvg -unlock vg03
To add a physical volume to a volume group :
# extendvg vg3 hdisk3
To remove a PV from a VG :
# reducevg vg01 hdisk1
To remove a PV and all residing LVs from a VG with no confirmation :
# reducevg –rmlv –f vg01
To activate a vg :
# activatevg vg03
To deactivate a vg :
# deactivatevg vg03
To mirror the VIO Server’s rootvg to hdisk4 and reboots VIO Server :
# mirrorios –force hdisk4
To mirror the VIO Server’s rootvg to hdisk4 but don’t reboot the server :
# mirrorios –defer hdisk4
To remove the rootvg mirror from hdisk4 :
# unmirrorios hdisk4
To import a VG from hdisk07 :
# importvg –vg vg001 hdisk07
To export a VG :
# exportvg vg3
Note: Volume Group containing a paging space can’t be exported
To sync a VG :
# syncvg –vg vg01
To sync a LV :
# syncvg –lv lv001
To sync a PV :
# syncvg –pv hdisk4 hdisk5
To redefine a VG based on the VGDA from hdisk04 :
# redefvg –dev hdisk04
Logical Volume :
To create a logical volume of size 1MB in vg01 :
# mklv –lv lv001 vg01 1M hdisk1
To create a logical volume with mirror in place in vg01 of size 1GB :
# mklv –mirror vg01 1G
To extend an LV by 3MB :
# extendlv lv01 3M
To extend an LV by 1GB with space taken from hdisk5 :
# extendlv lv01 1G hdisk5
To remove a logical volume :
# rmlv lv05
To display the properties of a logical volume :
# lslv lv03
To display info about LV by Physical volume :
# lslv –pv lv03
To display LVs that can be used as backing devices :
# lslv –free
To make a copy for lv01 in hdisk03 :
# mklvcopy lv01 hdisk03
To remove lv01’s copy from hdisk03 :
# rmlvcopy lv01 hdisk03
To copy the contents of lv01 to lv02 :
# cplv lv01 lv02
To copy the contents of lv01 to a new lv in vg01 :
# cplv –vg vg01 lv01
To change the name of oldlv to newlv :
# chlv –lv newlv oldlv
Physical Volume
To display all physical volumes in the system :
# lspv
To display the status and characteristics of hdisk03 :
# lspv hdisk03
To list all the available PVs used as virtual SCSI backing devices :
# lspv –avail
To list PVs that can be used as virtual SCSI backing devices and are not currently a backing device :
# lspv –free
To move physical partitions from hdisk1 to hdisk2 :
# migratepv hdisk1 hdisk2
To move physical partitions in lv01 from hdisk1 to hdisk2 :
# migratepv –lv lv01 hdisk1 hdisk2
Storage Pool Management:
To create storage pool “client_data” using hdisk3 hdisk4 hdisk3 and hdisk4 :
# mksp -f client_data
To set client_data storage pool as default :
# chsp –default client_data
To list all storage pools :
# lssp
To list the default storage pool :
# lssp –default
To list the backing device in rootvg storage pool :
# lssp –bd –sp rootvg
To attach a storage from a storage pool to a Virtual SCSI adapter:
# mkbdsp -bd lv001 -vadapter vthost2 -tn vtscsi9
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –bd lv001
To remove storage from a Virtual SCSI adapter, And makes sure backing device is not deleted :
# rmbdsp –bd lv001 -savebd
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –vtd vtscsi9
To removes storage from a Virtual SCSI adapter. and makes sure backing device is not deleted :
# rmbdsp –vtd vtscsi8 -savebd
Network Configuration :
TCP/IP Configation:
To configure tcpip on a network interface :
# mktcpip -hostname sys01vio2 -inetaddr 9.47.90.113 -interface en2 -netmask 255.255.255.0 -gateway 9.47.90.1 -nsrvdomain yahoo.com -start
-
To display the stored tcp/ip configuration in the system :
# lstcpip –stored
To display ethernet adapters on the system :
# lstcpip –adapters
To display the system hostname :
# lstcpip –hostname
To display DNS name servers in search order and domain name :
# lstcpip –namesrv
To display the routing table :
# lstcpip –routtable
To display routing table in numeric output instead of hostname :
# lsctpip –num –routtable
To display all the open inet sockets :
# lstcpip –sockets –family inet
To display the status of all configured interfaces :
# lstcpip –state
To remove all TCP/IP configuration :
# rmtcpip –all
To unconfigure tcpip in en0:
# rmtcpip –interface en0
To cleanup static routing table :
# rmtcpip –f -routing
To remove IP information from en0 after reboot :
# rmtcpip –f –interface en0 -nextboot
To remove DNS information and clears the hosts file :
# rmcpip –namesrv
Managing IP address-to-host name Mapping Entries:
To add IP address-to-host name mapping entry :
# hostmap -addr 192.100.1.7 -host alpha
To list all IP address-to-host name mapping entries :
# hostmap –ls
To delete the IP address-to-host name mapping entry :
# hostmap-rm 192.100.1.7
Managing Network Services:
To enable all the network services :
# startnetsvc ALL
To enable the telnet daemon :
# startnetsvc telnet
To enable the ftp daemon :
# startnetsvc ftp
To enable the ssh daemon :
# startnetsvc ssh
To enable the ldap daemon :
# startnetsvc ldap
To enable the cimserver daemon :
# startnetsvc cimserver
To enable the xntpd daemon :
# startnetsvc xntpd
To send CLI tracing details to the system log :
# startnetsvc tracelog
To send system error to the system log :
# startnetsvc errorlog
To disable all the network services :
# stopnetsvc ALL
To disable the telnet daemon :
# stopnetsvc telnet
To disable the ftp daemon :
# stopnetsvc ftp
To disable the ssh daemon :
# stopnetsvc ssh
To disable the ldap daemon :
# stopnetsvc ldap
To disable the cimserver daemon :
# stopnetsvc cimserver
To disable the xntpd daemon :
stopnetsvc xntpd
To stop sending CLI tracing details to system log :
# stopnetsvc tracelog
To stop sending system error log to the system log :
# stopnetsvc errorlog -
To display the status of ftp network service :
# lsnetsvc ftp
Managing DNS, Domain and Search Order Entries:
To add a domain entry :
# cfgnamesrv -add -dname abc.aus.century.com
To add a name server entry :
# cfgnamesrv –add -ipaddr 192.9.201.1
To display all the DNS entries :
# cfgnamesrv -ls
Network Tuning Parameters:
To display the maximum size of the mbuf pool :
# optimizenet –get thewall
To set a machine as internet work router over TCP/IP networks :
# optimizenet –set ipforwarding=1
To display information on udp_recvspace :
# optimizenet –h udp_recvspace
Network Monitoring:
To display all the statistics, including the device- specific statistics :
# entstat ent0
To reset all the statistics back to their initial values :
# entstat –reset ent0
To display the route to a particular host :
# traceroute nis.nsf.net
System Monitoring :
To display the summary of current system activity :
# sysstat
To display the system statistics :
# topas
System Management Commands:
To halt the operating system :
# shutdown
To halt the operating system forcibly :
# shutdown –force
To reboot the vio server :
# shutdown –restart
To invalidate the boot list for service mode :
# bootlist -mode service –rm
To display the boot list for service mode :
# bootlist -mode service –ls
To set the boot list for normal mode :
# bootlist –more normal hdisk0
To display the complete detailed error report :
# errlog –ls
To remove all the error log entries :
# errlog –rm 0
To remove the error log entries older than 5 days :
# errlog –rm 5
To change the system date and time :
# chdate -day 12 -month 10 -year 2004 -hour 16 -minute 30
To change the language for the entire system to French Canadian :
# chlang -lang fr_CA
To display available languages :
# chlang –ls
To perform hardware problem determination and maintenance :
# diagmenu
To generate report on microcode levels of all the devices :
# invscout –report
To display the vpd survey of the partition :
# invscout –vpd
To append the current MOTD [Message Of The Day] :
# motd –append “Message”
To overwrite MOTD :
# motd –overwrite -file filename
To do the initial configuration of VIO Server :
# cfgassist
It is like configuration assitant in AIX.
To do filesystem scan :
# fsck /dev/lv01
To display exported (nfs) directories on a remote server :
# showmount hostname
To start system dump on the primary device :
# startsysdump
To display continuous disk report on disk1 at 2sec interval :
# viostat -disk disk1 2
To display adapter throughput reports :
# viostat –adapter
To display system and adapter throughput reports :
# viostat –sys –adapter
To gather system info and to store it in the floppy disk :
# snap -general -dev /dev/rfd0
To display microcode levels of all devices :
# lsfware –all
Managing Agents:
To start an agent : # startsvc agent_name
To stop an agent: # stopsvc agent_name
To display an agent’s configuration information :
# lssvc agent_name
To display all the available agents :
# lssvc
To display the attributes associated with ITSM_base agent :
# cfgsvc –ls ITM_base
To display the ITM_base agent ssh public key :
# cfgsvc -key ITM_base
User Management:
To create a user :
# mkuser
To change an attribute of a user :
# chuser
To display the properties of a user :
# lsuser
To remove a user from the system :
# rmuser
To set/reset password for a user :
# passwd
Security Commands:
To display all failed logins :
# lsfailedlogin
To display the contents of global command log :
# lsgcl
To displays high system settings :
# viosecure -level high
To apply all of the high system settings to the system :
# viosecure -level high –apply
To displays the current system settings :
# viosecure –view
To allow IP activity on the ftp-data, ftp, ssh, www, https, rmc, and cimon ports, and to deny other IP activity :
# viosecure –firewall on
To enable IP activity on all ports :
# viosecure –firewall off
To display the list of allowed ports :
# viosecure -firewall view
tags: command, VIOS, Virtual-I/O-Server
« Adding a disk to GPFS filesystem Dynamically « newer
older » Run “update_all” using command line »
No Responses to "Virtual I/O Server(VIOS) useful commands". Add a comment? or Follow comments by RSS?
Be the first and share your thoughts!
Please leave a comment...
Stay behind your words, use your real name or nickname.
name »
e-mail »
site »
Please be nice and tolerant, don't offend. Thanks!
Home
About
RSS Feed
Search for:
May 2012 M T W T F S S
« Apr
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31
Tag cloud
SEA HACMP Oracle NIC command LDAP VIO recovery HMC IBM AIX ODM mksysb filesystem process lvm powerha sendmail backup VG console login NIM tuning NPIV tcpip network restore jfs2 TSM VIOS performance disk GPFS device paging-space security SSH debug Boot WPAR Error linux NFS Remove
Categories
AIX (816)
application (8)
Cluster (27)
Database (13)
Fun (5)
HPUX (6)
linux (32)
Misc (5)
network (6)
Perl (5)
security (2)
Shell Script (27)
Solaris (29)
Storage (35)
TSM (20)
UNIX (3)
UNIX Interview questions and answers (3)
Virtualization (23)
Webspere (1)
Blogcatalog
Technology Blogs - Blog Catalog Blog Directory
Promote Your Blog
Recent Posts
List WWPN of all LPARs or a specific LPAR using HMC command
Yup, another PowerHA bug! cl_chfs: VG sharedvg is concurrent
Determining if TSAMP/RSCT rebooted a node/server
GPFS filesystem outage with a kernel panic 225E3B63
DBI1122E after using db2iupdt command on existing instance
Oracle installation compiler requirement
MustGather: No response (hang) on AIX 5.2 and higher versions produces no javacore
SEA Failover flapping on backup SEA
Optimizing Sybase Adaptive Server Enterprise (ASE) for IBM AIX
Upgrading CAA in a PowerHA v7.1 Cluster
SAS 9.2 on IBM AIX 7.1: Tuning guideline
SAS on IBM AIX 6.1: Tuning guidelines
SAS AIX 5L Tuning Guide
Running SAS applications on Virtual I/O based storage configuration
Live Partition Mobility for Oracle RAC
Search Engine Optimization and SEO Tools
TopOfBlogs
Search Engine Submission - AddMe
Blogroll
Themes
UNIX
unix.com
Meta
Log in
RSS Feed
Comments RSS
AIX Solaris HPUX UNIX Linux system storage administration ksh/perl scripting 2010. "Life is Simple" is a simple theme for WordPress, powered by Chereshka.
StatCounter - Free Web Tracker and Counter
Comments
Post a Comment